Jon-Michael Deldin

BMX, bike trials, & software from the Pacific Northwest

Managing OpenSSL and Curl with Older Rubies

One of the projects I run for work uses Ruby 1.9 and will probably not be upgraded to 2.x anytime soon. I’ve been running it inside a Vagrant box with an older version of Ubuntu, but I finally upgraded the machine only to die by a thousand tiny cuts. Here are a couple of tips if you’re working with older Ruby software and sick of finding other people’s stacktraces on the internet:


Ruby < 2.3 is incompatible with OpenSSL 1.1+ and will not build. It’s an easy fix:

sudo apt install libssl1.0-dev

libcurl4 / libcurl4-openssl-dev are incompatible with libssl1.0-dev

sudo apt install libssl1.0-dev libcurl3 libcurl-openssl1.0-dev

Then rbenv or compile Ruby and you should be able to install Typhoeus or other libcurl gems.


The above commands work on Ubuntu <= 18.04 (Bionic Beaver). I have not found a fix for 19.04 Disco Dingo yet.

* * *